Dela upp sifferkombination excel

Dela upp sifferkombination excel

Hej.
Ny här..
Jag har en databas i excel där det i en kolumn finns angivet telefonnummer med formeln som i utland, exempelvis 46712345678

Jag behöver nu ändra till svensk formel, alltså bort med landskoden ”46” och ersätta med ”0”, så att telefonnr blir 0712345677

Mycket tacksam för hjälp. Kan såklart göra det i flera etapper om så behövs.

Sök och ersätt? Alltså söka efter +46 i kolumnen och ersätta detta med 0.

Om du måste använda en formel
BYT.UT(A1;46;0;1)
Letar i cell A1 efter "46", byter ut den första träffen från vänster till till "0".

Skrivet av henkiii:

Om du måste använda en formel
BYT.UT(A1;46;0;1)
Letar i cell A1 efter "46", byter ut den första träffen från vänster till till "0".

Går inte det åt skogen om du har ett telefonnummer som inte börjar med 46 men innehåller det? Nu förstår jag TS som att alla nummer börjar på 46 men ändå.

Skickades från m.sweclockers.com

Tusen tack. Ska prova detta imorgon när jag har excel tillgängligt.

Alla nummer börjar med 46 (utom ett fåtal norska med 47) så även om det är folk med vanlig hemtelefon från Lund (med riktnummer 046) så står du den som 4646111111.
Då borde inte båda 46 försvinna!?

@36strobe46:

steg för steg

1# ställ dig i B1 (om första fältet finns i A1)
2# skriv =Right(A1,2) (trimma bort de två första tecken från vänster)
3# clona ner formelen så den ersätter alla celler.

Skrivet av Napoleongl:

Går inte det åt skogen om du har ett telefonnummer som inte börjar med 46 men innehåller det? Nu förstår jag TS som att alla nummer börjar på 46 men ändå.

Skickades från m.sweclockers.com

Jo då får man ju peta in en liten kontroll på det.
Typ:
=OM(VÄNSTER(A1;2)="46";ERSÄTT(A1;1;2;0);A1)

Skrivet av cg_thi:

1# ställ dig i B1 (om första fältet finns i A1)
2# skriv =Right(A1,2) (trimma bort de två första tecken från vänster)
3# clona ner formelen så den ersätter alla celler.

Njä, med den där formeln så plockar du bara fram de två sista siffrorna i telefonnumret. (och du får inte in den inledande nollan heller)

*edit*
Man kan skriva tex
=0&EXTEXT(G7;3;99)
=0&HÖGER(a1;LÄNGD(a1)-2)

men då är nog byt.ut enklare

Senast redigerat 2019-05-23 20:10
Skrivet av henkiii:

Jo då får man ju peta in en liten kontroll på det.
Typ:
=OM(VÄNSTER(A1;2)="46";ERSÄTT(A1;1;2;0);A1)

Ja det är väl det enklaste sättet, där uttrycket på riktiga Excel är: =IF(LEFT(A2;2)="46";REPLACE(A2;1;2;0);A1)

Svensk Excel är något man bör undvika, då man hela tiden får problem med att den ej inte ens har samma formler som 99,9% av alla excelexempel på internet har. Det blir också knepigheter att dela ens lösningar till folk som använder den riktiga excel. Inte minst när man från vba kodar formler.

Senast redigerat 2019-05-23 20:34

@Johan86c: Svensk excel ftl. Men är det inte "komma" istället för semikolon i den engelska versionen?

Enkelt.

Sätt en bokstav från början, tex "Z".

Sök och Ersätt: Z46 med 0

Done :>

Ett sätt för att sätta in Z från början är att använda formeln sammanfoga så kör du ihop 2 kolumner.

A1: Z
B1: 46763465728
=sammanfoga(a1,b1)

= Z46763465728

Ersätt Z46 med 0

= 0763465728

Skrivet av henkiii:

@Johan86c: Svensk excel ftl. Men är det inte "komma" istället för semikolon i den engelska versionen?

Det beror på ens inställning i Windows: https://www.officetooltips.com/office_2016/tips/change_the_se...

Egentligen borde man gå över till engelsk inställning på allt. detta med olika språkinställningar ställer till med så mycket problem som helst, där svensk Excel är ett av de värsta program gud har skådat.