AMD Ryzen 3000 "Matisse" – samlingstråd

Fin skit, tror jag lyckats stabilisera 3800MT/s med cl16 & 1900MHz 1:1, trodde först det var minnena som inte ville så högt men det verkar vara minneskontrollern/IOdie som ville ha mindre spänning med ökad FCLK.

Kunde nämligen köra 1900MHz FCLK osynkat och 3800MT/s minneshastighet med kontrollern i halvfart men så fort jag körde synkat rakt av med minneskontroller i 1:1 mot bussen så ville det helt enkelt inte bli stabilt oavsett, låg på 1.125V för SoC vid 1800/3600 men för att få 1900/3800 stabilt så backade jag till 1.095V på SoC samt sänkte VDDG IOD till 1,05V från 1,075V och VDDG CCD till 1V från 1.05V.

Har även finputsat LLC för SoC så den håller sig väldigt stabil och justerat upp växelfrekvensen till 600KHz, VRM på detta bord går löjligt sval så det finns nog utrymme att höja även till 1000KHz men det brukar inte ge någon extra stabilitet direkt.

Detta har nu överlevt stabilitestest betydligt längre än det gjort innan så vi får se om det landar i full stabilitet i slutändan.

Lite drygt 7 timmar i prime följt av lite drygt 7 timmar i HCI memtest, tror jag törs drista mig till att påstå detta vara stabilt.

Senast redigerat 2020-07-23 07:49

Ny Amd Chipset driver har kommit. Revision 2.07.14.327
AMD Ryzen™ Power Plans (required for UEFI CPPC2 in Windows® 10 May 2019 Update)
https://www.amd.com/en/support/chipsets/amd-socket-am4/x570

Skrivet av Jonas79:

Ny Amd Chipset driver har kommit. Revision 2.07.14.327
AMD Ryzen™ Power Plans (required for UEFI CPPC2 in Windows® 10 May 2019 Update)
https://www.amd.com/en/support/chipsets/amd-socket-am4/x570

Kunde inte installera den. Nu gick det efter andra försöket.

Senast redigerat 2020-07-23 11:43

Riktigt bra Chipset drivers detta.

Installerade nya chipset drivrutinen. Sen gick jag från datorn, upptäckte sen att HWinfo64 som alltid är igång va nersläckt. Hmm, har datorn startat om?
Men upptäckte sen att viloläge va aktivt, så inaktiverade detta. Men lite märkligt att HWinfo64 slocknar ner vid viloläge? Datorn har ju startat upp själv ur viloläget. Brukar aldrig köra de aktivt, släcka skärmarna är ok.

Skrivet av TaunyTiger:

Installerade nya chipset drivrutinen. Sen gick jag från datorn, upptäckte sen att HWinfo64 som alltid är igång va nersläckt. Hmm, har datorn startat om?
Men upptäckte sen att viloläge va aktivt, så inaktiverade detta. Men lite märkligt att HWinfo64 slocknar ner vid viloläge? Datorn har ju startat upp själv ur viloläget. Brukar aldrig köra de aktivt, släcka skärmarna är ok.

Satte min på 30 minuters sleeptimer per default vid installationen också utan att jag såg det, den gick till & med ner i sovläge under pågående prime95 blend test

Skrivet av tellus82:

Satte min på 30 minuters sleeptimer per default vid installationen också utan att jag såg det, den gick till & med ner i sovläge under pågående prime95 blend test

Haha va fan. 100% cpu belastning förväntar man ju sig ingen sleep iallafall. Tänk om man renderar en längre video, får man gå och röra på musen varje 29:e minut annars. Enklast är ju såklart att inaktivera de direkt, men med sådan belastning så ska datorn inte gå i sleep oavsett om man rört på musen eller ej.

Hände inte mig. samma inställningar som tidigare är kvar, men jag har bara testat på Windows 10 20175 ännu

Skrivet av the squonk:

Hände inte mig. samma inställningar som tidigare är kvar, men jag har bara testat på Windows 10 20175 ännu

Windows 10 1909 ännu.

Ett litet tips till er med MSI moderkort (inte alla deras bord har detta program men en del) , använd inte dragon center med deras sdk, det ger mer eller mindre en kontinuerlig 1% last på processorn som ställer till precision boost en hel del och introducerar en del stutter i spel. En hel del mjukvaror från många mobo tillverkare gör sig skyldig till detta men MSI är lite speciella då de bakar in alla tillbehörsprogram i ett och man kan heller inte välja vad man vill köra då allt ligger aktivt i bakgrunden som en service/tjänst i Windows oavsett aktiv del i programmet eller ej.

Inte superimponerad av detta men det är jag å andra sidan inte av Asus, asrock eller de andras mjukvara heller... Men för den som undrar vad som ligger och jobbar konstant så är det dragon center/sdk'n om ni har den installerad.

Skrivet av tellus82:

Ett litet tips till er med MSI moderkort (inte alla deras bord har detta program men en del) , använd inte dragon center med deras sdk, det ger mer eller mindre en kontinuerlig 1% last på processorn som ställer till precision boost en hel del och introducerar en del stutter i spel. En hel del mjukvaror från många mobo tillverkare gör sig skyldig till detta men MSI är lite speciella då de bakar in alla tillbehörsprogram i ett och man kan heller inte välja vad man vill köra då allt ligger aktivt i bakgrunden som en service/tjänst i Windows oavsett aktiv del i programmet eller ej.

Inte superimponerad av detta men det är jag å andra sidan inte av Asus, asrock eller de andras mjukvara heller... Men för den som undrar vad som ligger och jobbar konstant så är det dragon center/sdk'n om ni har den installerad.

Väl värt att upprepa.

https://www.sweclockers.com/forum/sok?searchid=c27b5053-afe9-...

@bagaget:
Länken lirade inget vidare för mig, vad ville du länka till?

Skrivet av tellus82:

@bagaget:
Länken lirade inget vidare för mig, vad ville du länka till?

Aha - det går tydligen bara att länka sökresultat i en timme... https://www.sweclockers.com/forum/trad/1568077-gar-inte-att-l...

Sökte på mina gamla inlägg om DragonCenter.

#18017275
#17994021
#17994017
#18514089

Skrivet av Ozzed:

Vad är det för bräda, den i signaturen (MSI B450I Gaming Plus AC )? Känner du till om det är daisy chain eller T-topologi? 400-serien har ju även den bättre kvalitet på ledningsbanorna än 300-serien. Såhär i efterhand så är det svårt att förstå att AMD inte ställde högre krav vid lansering av Ryzen, då många som lät bli att köpa gjorde det just för att minnesordet och hastigheten man kunde uppnå var skit jämfört med Intel, var väl sällsynt att komma över 3200Mhz ens med B-die på 1000-serien.

När jag hade X370 Prime Pro var 3200Mhz en hård gräns, och nu sitter jag med 3900X på ett Crosshair VII Hero och kör samma minnen i 3800Mhz. Sen har det väl såklart också att göra med att IMC/UMC blivit bättre med varje generation, men i många fall så verkar moderkorten vara en flaskhals, vilket är synd, för folk antar automagiskt att det är processorerna som inte orkar.

Kan tillägga att jag upplevde kraftig skillnad i positivt bemärkelse med Asus X370 Prime Pro brädan tillsammans med Ryzen 3700X som jag har nu jämfört med Ryzen 1600X.

Jag nöjde mig också med 3200MT/s på 1600X (kunde inte få det stabilt snabbare) men nu med 3700X kör jag stabilt i 3600MT/s med samma RAM.

Tror nog att det fanns en del som släppte deras X370 Prime Pro brädor lite väl tidigt eller åtminstone för väldigt små prestanda vinster. Nu är dock situationen lite annorlunda eftersom Asus X370 Prime Pro inte kommer få stöd för Zen 3.

Dock så är det intressant nu att se om version 5220 var den sista officiella versionen av bios för Asus X370 Prime Pro eller om det faktiskt kommer en ny version nu i slutet av juli. Asus X470 Prime Pro fick ju en ny bios version nyligen medan bios version 5220 för X370 Prime Pro släpptes 2019/09/24 så det var en låång tid sedan. Jag kör dock med en test/beta BIOS 5406.

Senast redigerat 2020-07-24 16:30
Skrivet av bagaget:

Aha - det går tydligen bara att länka sökresultat i en timme... https://www.sweclockers.com/forum/trad/1568077-gar-inte-att-l...

Sökte på mina gamla inlägg om DragonCenter.

#18017275
#17994021
#17994017
#18514089

Ahh, då fattar jag, hade själv inte sökt mycket på just dragon center & msi så jag hade inte kommit i kontakt med det så mycket, de burkar jag bygger ihop brukar jag skippa bloatware på men provade till min egna burk & det är som du säger något man kan undvika

Sitter här mitt-i-natta och funderar, är det dags att uppdatera BIOS?

Är fortfarande kvar på release BIOS till mitt ASUS Strix x570-f gaming. Förutom för att jag fortfarande får Whea error 17 (dock inget som påverkar min användarupplevelse om man inte tittar i windows loggboken), och jag inte kan starta Starcraft 2 (av någon oförklarlig anledning, inte lyckats härleda felet) samt att Ryzen master kraschar ganska omgående (oklart om det är bios fel, men har uppdaterat RM, nvidia drivruter etc men problemet kvarstår) så har jag inga upplevda problem.
D.v.s för dagligt bruk så funkar det som det ska.

Hur ser det ut, är det rekommenderat att uppgradera? Förutom att förhoppningsvis fixa ovanstående, finns det några ev. prestandavinster / förluster att hämta?

Har inte hängt med så mycket i tråden sen i höstas, då det blev mest minnesöverklockning diskussion.

@norzma: Det är alltid en risk att uppdatera bios så är man orolig eller bara har tillgång till en dator kan det vara smart att låta bli om allting fungerar.

Med det sagt, Asus har släppt en drös nya bios för olika brädor, jag kör dom nya bios på C7H, X470-Prime Pro och B550-F. På samtliga kan man notera snabbare uppstart och jag har fått bättre OC och minnesprestanda på samtliga. Jag har till och med fått min gamla 2700X att klara 3000MT med 4x Hynix AFR vilket den inte klarade ens på C7H tidigare, det var tvärnit över 2933. På C7H har CCX OC tillkommit vilket jag har haft användning för.

Dom nya biosen har helt ny AGESA bas, om du uppgraderar använd för tusan Bios Flashback knappen på baksidan och försök inte uppgradera inifrån bios. Vid första boot ladda Optimized Defaults och boota om igen innan du ställer in något. Använd inte en gammal profil, du bör knappa in allting på nytt som du vill ha det.

edit. Apropå olika brädor, jag verkar ha gjort rätt val med B550-F, jag använder det kortet på min DAW-dator som har all programvara för det ändamålet installerad. Anandtech testade B550-F och uppmätte den lägsta DPC-latency dom någonsin har uppmätt på någon Ryzen-bräda. Just för ljud vill man ha så låg DPC-latency som möjligt så det var ett lucky shot

Testat en del med WSL efter senaste Windows releasen men man ser under benchmarks som tex Cinebench R20 att funktioner som SVM i bios samt Hypervisor i Windows stjäl lite prestanda. Jag får runt 3% sämre i multicore prestanda med features som behövs för WSL påslagna. Spelar mindre roll för helheten men för oss som sporadiskt kör benchmarks är det bra att vara medveten om.

Diskuteras tex här:
https://www.reddit.com/r/Amd/comments/depxrl/can_someone_conf...

Senast redigerat 2020-07-25 10:44

Hmmm, kört en del Cinebench R20 idag, var lite frustrerad över att jag inte längre nådde över 5000 på min 3700X som tidigare. Nådde nu ca 4950 och började grejade lite.

Minns inte riktigt när det var jag nådde 5000 sist men det var nog innan Windows 10 version 2004 och innan jag började greja med ovan nämnda WSL (Windows Subsystem for Linux) och Hypervisor tjänsterna, SVM i bios etc vilket kan påverka prestandan lite negativt. Dock vet jag att jag brukade få värde på strax över 5000 under en ganska lång tid innan Windows 10 version 2004 (innan jag började testa med WSL).

Hur som helst, nu till min fråga...

I PBO inställningarna för min 3700X på mitt Asus X370 Prime Pro har jag läänge kört med

ppt 122W
tdc 86
edc 89
100MHz
Scalar = 7x
auto på throttle limit

Började googla lite idag och förstod att en del kör med 1 som värde på EDC.

När jag testade det sköt mitt Cinebench R20 multicore resultat i höjden till 5050 direkt?! Nytt pb för övrigt men blev nästan lite snopen.

Jag kör med 5406 beta bios (Agesa 1.0.0.4B) på mitt Asus X370 Prime Pro

Vad gör egentligen värde 1 på EDC, kan detta vara ett dåligt/farligt värde? Har läst om att EDC ska ha någon sorts bugg på Agesa 1.0.0.4B En del sätter därför EDC = 0, andra till maxvärdet för 3700X, dvs till EDC = 90 men sedan började jag läsa om att sätta EDC = 1 och tänkte att jag testar väl.

Tänkte att någon av er kan upplysa mig.

Vet inte ännu om det är stabilt för mig med EDC = 1 men multicore i Cinebench R20 sköt uppenbarligen i höjden.

Senast redigerat 2020-07-25 19:41
Skrivet av makatech:

Hmmm, kört en del Cinebench R20 idag, var lite frustrerad över att jag inte längre nådde över 5000 på min 3700X som tidigare. Nådde nu ca 4950 och började grejade lite.

Minns inte riktigt när det var jag nådde 5000 sist men det var nog innan Windows 10 version 2004 och innan jag började greja med ovan nämnda WSL (Windows Subsystem for Linux) och Hypervisor tjänsterna, SVM i bios etc vilket kan påverka prestandan lite negativt. Dock vet jag att jag brukade få värde på strax över 5000 under en ganska lång tid innan Windows 10 version 2004 (innan jag började testa med WSL).

Hur som helst, nu till min fråga...

I PBO inställningarna för min 3700X på mitt Asus X370 Prime Pro har jag länge kört med

ppt 122W
tdc 86
edc 89
100MHz
Scalar = 7x
auto på throttle limit

Började googla lite idag och förstod att en del kör med 1 som värde på EDC.

När jag testade det sköt mitt Cinebench R20 multicore resultat i höjden till 5050 direkt?! Nytt pb för övrigt men blev nästan lite snopen.

Jag kör med 5406 beta bios (Agesa 1.0.0.4B) på mitt Asus X370 Prime Pro

Vad gör egentligen värde 1 på EDC, kan detta vara ett dåligt/farligt värde? Har läst om att EDC ska ha någon sorts bugg på Agesa 1.0.0.4B En del sätter därför EDC = 0, andra till maxvärdet för 3700X, dvs till EDC = 90 men sedan började jag läsa om att sätta EDC = 1 och tänkte att jag testar väl.

Tänkte att någon av er kan upplysa mig.

Vet inte ännu om det är stabilt för mig med EDC = 1 men multicore i Cinebench R20 sköt uppenbarligen i höjden.

Om jag minns rätt så är det en bug som stänger av FIT-tabellen när man sätter EDC till 1, så processorn tar inte hänsyn till kvalitet på kislet när den justerar spänning med mera. Man får bättre prestanda men tar bort en viktig skyddsmekanism mot degradering, så det är inget jag skulle rekommendera att köra på lång sikt.

Skrivet av Ozzed:

Om jag minns rätt så är det en bug som stänger av FIT-tabellen när man sätter EDC till 1, så processorn tar inte hänsyn till kvalitet på kislet när den justerar spänning med mera. Man får bättre prestanda men tar bort en viktig skyddsmekanism mot degradering, så det är inget jag skulle rekommendera att köra på lång sikt.

Ahh, jag misstänkte att det skulle ha någon negativ effekt.

Ok, start tack för upplysningen!!

@makatech: Jag får mellan 5050-5100, 5104 som mest, utan EDC bugg. Men processorn är välkyld och är det något som stämmer när det gäller Ryzen så är det att Auto/PBO-resultaten styrs helt av temperatur. Det är det man kan kringgå med manuell klockning om man vill(eller EDC bugg).

@Ozzed @the squonk Hehe, ok, ja, jag får läsa på lite mer om EDC = 1 om jag verkligen ska köra systemet med den inställningen men jag blev nästan snopen över den omedelbara boosten.

Behöver i så fall också monitorera mer med hwinfo och/eller ryzen master för att se hur systemet beter sig.

Skrivet av tellus82:

Global C-state Control = Enabled
DF Cstates = Enabled
Power Supply Idle Control = Low Current Idle
CPPC = Enabled
CPPC Preferred Cores = Enabled
AMD Cool'n'Quiet = Enabled
PPC Adjustment = PState 0

Andra saker som kan påverka boost negativt är för höga spänningar med VDDG/VDDP/SoC, slask program igång i bakgrunden som ligger & väcker kärnor hela tiden, gammal version av windows osv.

Förutom att mitt MSI x470 gaming plus inte hade DF Cstates så ställde jag in dom övriga inställningarna precis som du skrev, blir att testa och se hur det fungerar, tack för tipset! 👍

Skrivet av Bewise:

Förutom att mitt MSI x470 gaming plus inte hade DF Cstates så ställde jag in dom övriga inställningarna precis som du skrev, blir att testa och se hur det fungerar, tack för tipset! 👍

Inte alla bord har denna synlig, en del bakar in den i vanliga global c states.

Skrivet av tellus82:

Inte alla bord har denna synlig, en del bakar in den i vanliga global c states.

Då vet jag, tack för infon!

@Ozzed @the squonk @tellus82

Med dessa värden får jag single score 1332 och multiscore 10017 i Geekbench 5. Någon stabilitet har jag inte testat ännu men högst för mig hittills på min 3700X och Asus X370 Prime Pro bräda. Får testa vidare, lite kul trots allt med poängjakt och att slå lite pb, kräma ut det sista av min Asus X370 bräda. Inte EDC = 1 längre utan EDC = 10

ppt 122W
tdc 86
edc 10
100MHz
Scalar = 5x
auto på throttle limit

Senast redigerat 2020-07-26 20:27
Skrivet av makatech:

@Ozzed @the squonk @tellus82

Med dessa värden får jag single score 1332 och multiscore 10017 i Geekbench 5. Någon stabilitet har jag inte testat ännu men högst för mig hittills på min 3700X och Asus X370 Prime Pro bräda. Får testa vidare, lite kul trots allt med poängjakt och att slå lite pb, kräma ut det sista av min Asus X370 bräda. Inte EDC = 1 längre utan EDC = 10

ppt 122W
tdc 86
edc 10
100MHz
Scalar = 5x
auto på throttle limit

Intressant, kanske också skall testa!

( inte för att det skiljer mycket, 14p mer i single och 200p i multi mot min med allt på Auto )

Skrivet av the squonk:

Intressant, kanske också skall testa!

( inte för att det skiljer mycket, 14p mer i single och 200p i multi mot min med allt på Auto )

Jag har lugnat mig lite nu men kul att greja lite. Fina benchmarks (för att vara mitt system) men inte riktigt 100% stabilitet, möjligt det går att få till det men orkar inte just nu. Förlorar ju extremt lite på den inställning som jag brukar köra och som är stabil.

Står som sagt en del om detta här (EDC) och åsikterna verkar gå isär lite.
https://www.overclock.net/forum/13-amd-general/1741052-edc-1-...

@tellus82

Har nu kört med dom inställningarna du rekommenderade sen sist vi skrevs och måste säga att den går en aning stabilare samt svalare, får tacka!