Raspberry Pi 4

@BostonGurkan:

Jag satte statisk ip i routerns inställningar ( Asus RT-N66U ) och det fungerar bra.
Min Raspberry pi får alltså samma adress varje gång den startar.

Skrivet av Zirgo:

@BostonGurkan:

Jag satte statisk ip i routerns inställningar ( Asus RT-N66U ) och det fungerar bra.

Det kan du inte göra utan det måste göras i klienten, du kan möjligen ha valt att alltid tilldela samma ip via dhcp till en enhet men då är det fortfarande inte statisk ip utan man använder dhcp.

[quote postid="18270800" userid="130967" name="mrqaffe"]
du kan möjligen ha valt att alltid tilldela samma ip via dhcp till en enhet

Stämmer det var så jag gjorde.

Skrivet av mrqaffe:

Det kan du inte göra utan det måste göras i klienten, du kan möjligen ha valt att alltid tilldela samma ip via dhcp till en enhet men då är det fortfarande inte statisk ip utan man använder dhcp.

Nån skillnad i slutändan? Jag har försökt att hitta nån DHCP-inställning på min router men har inte lyckats klura ut vart man ändrar det isf. Finns väldigt begränsat med inställningar på den även i ”avancerat läge” (Basic router som ingick i abonnemanget).

Skrivet av BostonGurkan:

Nån skillnad i slutändan? Jag har försökt att hitta nån DHCP-inställning på min router men har inte lyckats klura ut vart man ändrar det isf. Finns väldigt begränsat med inställningar på den även i ”avancerat läge” (Basic router som ingick i abonnemanget).

Det kan vara det, man bör tex inte sätta statiska ip inom den adressområde dhcpservern arbetar.
Oftast men inte alltid går det bra men man bör vara observant på detaljerna när det gäller adressering för ibland uppstår det problem, en adress ska vara unik och ett vanligt fel är att man har samma förvalda statiska ip till flera olika admininterface typ 192.168.0.1 på flera olika ställen i lanet.
Nu är det ju inte så i den här frågan men hursomhelst så kan man bara sätta statiska ip i klienten för annars är det dhcpservern som tilldelar uppgifterna till klienten, servern kan visserligen följa något regelverk man kar konfat men det handlar ändå om adressering via dhcp.

@BostonGurkan:

Vilken router har du?

Skrivet av Zirgo:

@BostonGurkan:

Vilken router har du?

https://www.telia.se/privat/bredband/produkter-tillbehor/prod...

Denna verkar det som. Eller nån ideration under den. Fick den för 2 1/2 år sedan.

Skickades från m.sweclockers.com

@BostonGurkan:

Prova om detta fungerar:

Ställa in router

Skrivet av Zirgo:

Lyckades hitta hur man fixade via DHCP. Tack för hjälpen. Även om det kanske inte är optimalt i det långa loppet kanske jag kan få igång servern nu iaf!

@BostonGurkan:

Trevligt.

Min lösning har fungerat i flera år utan problem.
Har även läst att andra gjort samma sak.

Använder på min Android mobil detta för att utföra kommandon på Raspberry.

Raspicheck

Snabb fråga som jag inte hittar nått tydligt svar på: måste jag formatera min externa hdd innan jag kan använda den som lagring för Samba share, eller funkar en vanlig ntfs? Har en del videos och bilder på den som jag inte vill bli av med, så vill helst inte rensa den. Dvs går det att få pi:en att auto mounta den vid uppstart och använda med samba eller bör jag skaffa en ny hdd för den uppgiften?

Skickades från m.sweclockers.com

Skrivet av BostonGurkan:

Snabb fråga som jag inte hittar nått tydligt svar på: måste jag formatera min externa hdd innan jag kan använda den som lagring för Samba share, eller funkar en vanlig ntfs? Har en del videos och bilder på den som jag inte vill bli av med, så vill helst inte rensa den. Dvs går det att få pi:en att auto mounta den vid uppstart och använda med samba eller bör jag skaffa en ny hdd för den uppgiften?

Skickades från m.sweclockers.com

Det går bra att flytta disken förutsatt att den har ett lämpligt filsystem, Raspian stödjer inte exfat eller NTFS rakt av utan det måste installeras men du kan ju ha nått annat på disken också, tex fat32 har stöd från början liksom ext4 som är det som används av nästan alla linuxversioner idag.
Kör du win 10 på rpin så förutsätter jag att det stödjer ntfs rakt av men jag har inte provar.

Skrivet av mrqaffe:

Det går bra att flytta disken förutsatt att den har ett lämpligt filsystem, Raspian stödjer inte exfat eller NTFS rakt av utan det måste installeras men du kan ju ha nått annat på disken också, tex fat32 har stöd från början liksom ext4 som är det som används av nästan alla linuxversioner idag.
Kör du win 10 på rpin så förutsätter jag att det stödjer ntfs rakt av men jag har inte provar.

Tack! Fick det att funka utan strul.

Nytt problem dock: Försöker ansluta till en svensk NordVPN server via Openvpn på min pi, men det finns endast US, VN och ZA i listan över servrar. Försökt att leta rätt på hostname på en svensk server på NordVPN:s hemsida men när jag anger adressen som de säger är korrekt (ex. se282.nordvpn.com.udp) så får jag bara error. Går bra att ansluta till de amerikanska servrarna som listas på min pi men de har också några siffror bakom udp/tcp (ex. us-ca18.nordvpn.com.udp1194.ovpn) som jag inte kan finna bland de hostnames som NordVPN anger på sin webbsida. Antar att det är det som sätter käppar i hjulet för mig? Någon som vet vad jag gör fel?

Något tips på roligt projekt man kan påbörja?

Skrivet av deni123:

Något tips på roligt projekt man kan påbörja?

https://www.superbestaudiofriends.org/index.php?threads/dummi...

Senast redigerat 2020-02-03 13:19
Skrivet av BostonGurkan:

Tack! Fick det att funka utan strul.

Nytt problem dock: Försöker ansluta till en svensk NordVPN server via Openvpn på min pi, men det finns endast US, VN och ZA i listan över servrar. Försökt att leta rätt på hostname på en svensk server på NordVPN:s hemsida men när jag anger adressen som de säger är korrekt (ex. se282.nordvpn.com.udp) så får jag bara error. Går bra att ansluta till de amerikanska servrarna som listas på min pi men de har också några siffror bakom udp/tcp (ex. us-ca18.nordvpn.com.udp1194.ovpn) som jag inte kan finna bland de hostnames som NordVPN anger på sin webbsida. Antar att det är det som sätter käppar i hjulet för mig? Någon som vet vad jag gör fel?

Fick det att funka tillslut. Var bara så simpelt att man skulle lägga till en kod bakom udp respektive tcp.

Tack för inspirationen, fick plötsligt användning för min gamla Pi 1 som legat och skräpat i en låda i några år Får testa loss lite och se om den orkar och hur det funkar över HDMI, sen blire väl att skaffa en DAC-hat och få loss en Pi3 om det visar sig vara en bra grej.

Apropå DACs, så finns det också betydligt billigare dylika än den som föreslås i guiden. Priset kan nog verka lite lätt avskräckande på många

@kaput: Kul! Hoppas du delar med dig av resultatet.
Ja jo, finns ju en del att välja mellan men kan medge att jag inte satt mig in i om det är någon skillnad mellan dem.

Skrivet av backspace:

@kaput: Kul! Hoppas du delar med dig av resultatet.
Ja jo, finns ju en del att välja mellan men kan medge att jag inte satt mig in i om det är någon skillnad mellan dem.

Änsålänge verkar det faktiskt funka riktigt bra på Pi 1. Trodde det skulle ta dagar att indexera all musik, men icke, det gick på under en halvtimme skulle jag tro. Användargränssnittet känns också rappt och fint efter den initiala laddningen, är nog inga större mängder data det hämtar när browsern väl cachat grafik, css, osv.

Får väl återkomma senare om det visar sig att någon funktion ställer lite mer krav på hårdvaran, men so far so good i alla fall, och ett klart bättre användningsområde för det gamla hallonet än att agera lådvärmare iaf

Hehe, jo, bara nämnde det så den som inte vet droppar projektet omedelbart när vederbörande ser vad den föreslagna audiohaten - fel av mig att kalla den DAC - kostar. Utan att alls ha någon koll på ljud, om jag uppfattat det rätt är den där mest användbar om man vill ansluta till highend/proffsgrejor, men att det för gemene man bör räcka att trycka in ljudet i förstärkaren via HDMI

Skrivet av kaput:

Änsålänge verkar det faktiskt funka riktigt bra på Pi 1. Trodde det skulle ta dagar att indexera all musik, men icke, det gick på under en halvtimme skulle jag tro. Användargränssnittet känns också rappt och fint efter den initiala laddningen, är nog inga större mängder data det hämtar när browsern väl cachat grafik, css, osv.

Får väl återkomma senare om det visar sig att någon funktion ställer lite mer krav på hårdvaran, men so far so good i alla fall, och ett klart bättre användningsområde för det gamla hallonet än att agera lådvärmare iaf

Hehe, jo, bara nämnde det så den som inte vet droppar projektet omedelbart när vederbörande ser vad den föreslagna audiohaten - fel av mig att kalla den DAC - kostar. Utan att alls ha någon koll på ljud, om jag uppfattat det rätt är den där mest användbar om man vill ansluta till highend/proffsgrejor, men att det för gemene man bör räcka att trycka in ljudet i förstärkaren via HDMI

Jag hittade följande från en av människorna bakom pi2design.com (pi2aes)

Citat:

That said, the PI2AES has measurably lower jitter than the Hifiberry Digi + pro. Both products use the same AES transmitter, from the Cirrus WM880x family. Where they differ is the choice of low noise regulators and higher performance clock isolators that we use. This adds up to cost and so we are quite a bit more than the hi-fi berry products.

Skrivet av backspace:

Jag hittade följande från en av människorna bakom pi2design.com (pi2aes)

Hehe, när ljudnördar snackar "mätbart" brukar det röra sig om skillnader mina tämligen oaudiofila öron aldrig i helvetet skulle uppfatta

Fattar dock inte riktigt hur det skulle vara bättre att köra över AES än HDMI, om det inte är en bandbredds- och sampleratefråga, eller rent av bara att man råkar ha en förstärkare som inte har HDMI-ingång? Att det är skillnad på olika kretsar, gränssnitt, etc. efter D/A-omvandlingen fattar jag, men när det rör sig om digital datatransport ser inte jag varför det skulle finnas kvalitetsskillnader mellan olika gränssnitt.

Har stött på ett störande problem med uppspelning av filmer lokalt på raspberry:n via VLC. Filmerna flyter på bra i fullscreen utan subs men så fort jag lägger till subs så blir det en märkbar frysning i bilden med jämna mellanrum när ny textdialog dyker upp. Har försökt googla upp fenomenet då jag aldrig stött på det förr och det verkar vara ett känt problem som dykt upp på en mängd olika maskiner och versioner av VLC de senaste 3-4 åren. Vad jag kan se kommer trådarna aldrig fram till någon lösning. Vissa hävdar att det är ett synkroniseringsfel mellan filmen och subsen om de inte är skapade för den specifika versionen men jag har testat en rad olika subs i en rad olika filmer som flyter på bra på min pc.

Har testat att spela upp filerna både från Root-SD och extern HDD med min pi men är ingen skillnad. Temperaturen ligger på strax över idle temp (runt 65-70 grader) och cpu-load är på ca 10-15% vid uppspelning, så det känns inte som det är en faktor som spelar in.

Någon som har några tips? Om det inte går att fixa kanske jag får byta till någon annan mediaspelare? När jag letat runt efter alternativ verkar det dock som att VLC är en av få vettiga program till rpi4 då det stödjer hårdvaruacceleration för gpu:n?

@BostonGurkan:
Har du testat att spela upp en äldre film (5+ år) under samma förutsättningar?
Det kanske är orelaterat då det är olika platformar men på min desktopdator från 2012 (intel core 2500k) så fick jag problem med VLC, när jag valde att köra processorn i mediumläge istället för high performance, likt det du beskrev (dock utan subs). Typ var 5:e sekund så hackade bilden till i en frysning. Men det gällde vara nyare filmer och inte äldre, så troligtvis var det att processorn blev för slö för nyare codecs/högre bildkvalité utan överklockningen.

Skrivet av ojz0r:

@BostonGurkan:
Har du testat att spela upp en äldre film (5+ år) under samma förutsättningar?
Det kanske är orelaterat då det är olika platformar men på min desktopdator från 2012 (intel core 2500k) så fick jag problem med VLC, när jag valde att köra processorn i mediumläge istället för high performance, likt det du beskrev (dock utan subs). Typ var 5:e sekund så hackade bilden till i en frysning. Men det gällde vara nyare filmer och inte äldre, så troligtvis var det att processorn blev för slö för nyare codecs/högre bildkvalité utan överklockningen.

Har svårt att tro att det är problemet då den flyter på bra vid uppspelning av mkv-filer i både 1080p och 720p med låg cpu-användnig. Rent prestandamässigt ska ju raspberryn orka med. Kan tillägga att jag har 4gb-versionen också och endast ca 20% av minne används.

Skickades från m.sweclockers.com

@ToddTheOdd: tack för förslaget men kodi verkar vara lite för resurskrävande för att endast startas när jag ska kolla på film på rasbian. Resten av tiden agerar rpi:n NAS och plex server så vill inte göra den till dedikerad mediabox.

Skulle vilja köpa en Raspberry Pi 4 för att kunna spela lite enklare spel på webläsaren och använda Discord, hur skulle det funka ? 🙂

Skickades från m.sweclockers.com

@Vasslepulver:

EDIT:

Svarade fel😪

@BostonGurkan: Själv kör jag aldrig annat än LibreELEC (Kodi) för mediauppspelning via Pi, VLC skulle jag aldrig använda pga alla problem det genererat på div Windowsdatorer under årens lopp.

Skrivet av MatteN:

@BostonGurkan: Själv kör jag aldrig annat än LibreELEC (Kodi) för mediauppspelning via Pi, VLC skulle jag aldrig använda pga alla problem det genererat på div Windowsdatorer under årens lopp.

Kör du via rasbian som en launcher eller använder du kodi som "operativsystem"?

Skickades från m.sweclockers.com