Uppgraderade till Linux Mint 19 Tara nu har jag problem med grafiken

Uppgraderade till Linux Mint 19 Tara nu har jag problem med grafiken

Hej

Jag har problem med grafiken i Linux Mint 19 Tara som jag nyligen uppgraderade till från 18.3. Problemet uppenbarar sig så att varje sekund så fryser bilden till. Omöjligt att se på film med andra ord. Jag kan inte installera senaste Nvidia drivrutinen via drivrutinshanteraren. Jag kan heller inte välja mellan olika fönsterhanterare annat än Cinnamon i inloggningskärmen. Trots att jag installerat Mate och Xfce4. Jag får även problem vid kallstart och då får jag innan inloggningskärmen en ett felmeddelande om att x-servern är felkonfigurerad och att jag ska ta bort filen /tmp/.X0-lock vilket jag gör emellanåt men det återkommer.

Jag hade egentligen ingen lust att installera om hela systemet även om det skulle vara skönt på ett sätt. Men jag funderar på att ta bort det grafiska gränssnittet med konfigfiler, dvs purge och installera om det. Kan det var rätt väg att gå?

Helst vill jag bara fixa grafikfelet och fortsätta använda datorn som den är.

Var ska jag börja felsöka?

Jag har ett Nvidia GTX970 grafikkort

Nu körde jag apt remove -pruge cinnamon och installerade om det, då dök de andra fönstarhanterna upp som alternativ när jag startade datorn. Nu flyter det på med videos, men jag har ännu inte lyckats installera den propetiära nvidia drivrutinen. Får se om det är nödvändigt.

Jag får detta fel då.

Följande paket har otillfredsställda beroenden:

nvidia-driver-435: Depends: libnvidia-gl-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: nvidia-dkms-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: nvidia-kernel-source-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-compute-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: nvidia-compute-utils-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-decode-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-encode-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: nvidia-utils-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: xserver-xorg-video-nvidia-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-cfg1-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-ifr1-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras
Depends: libnvidia-fbc1-435 (= 435.21-0ubuntu0.18.04.2) men 435.21-0ubuntu0.18.04.2 kommer att installeras

Nu ser jag att nvidia-driver-390 är installerad istället. Skumt detta.

Oberoende paket i flera led, nu har jag lyckats installera 435 drivern. Blev kanske lite onödig tråd detta men men..