Windows 10 installation och samsung 970 evo m2

Windows 10 installation och samsung 970 evo m2

Hej!

Har lite problem men att installera windows 10 och söker lite hjälp.

Jag ska alltså göra en ny ren installation med usb.
Använder mig av microsofts egna verktyg för usb

Problem 1:
Windows cannot be installed to this disk. The selected disk is not of the GPT partition style.

Löste det genom de här stegen.

Follow these steps -

1. At installation screen press Shift+F10 or Fn + Shift + F10 keys at the same time.

2. You will get Command Prompt at installation screen.

3. Type "Diskpart" and hit Enter.

4. Type "list disk" hit Enter.

5. It will show you all the disk into your computer. Now type "Select disk 'disk_no.'" Like "select disk 0" Hit Enter.

6. Type "clean" and hit Enter, cleaning your hard disk will erase the whole disk so be careful if you have any data on the disk. Make a backup before cleaning the disk.

7. Type "convert gpt" and hit enter.

If GPT doesn't work for you the Type "convert mbr" OR "convert basic".

8. Exit the command prompt and proceed with the Windows installation.

Jag kunde då installera windows

Problem 2. fick det här efter jag löst första
windows 10 cannot be installed to this disk hardware may not support booting.

Försökt fixa med det här
edit: och lyckades starta windows installationen.

Compatibility Support Mode - set to [DISABLED]

Secure Boot

1- The M.2 drive has to be the only drive installed.

2 - Go into the BIOS, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, not Windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that Windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode. (see #3 above)

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

edit: Problem 3
När jag gjorde intruktionerna ovan för att lösa problem 2 så fastnar jag på steg 8. Efter windows installationen syns inte ssd:en i bios? Trots att installationen gick bra? Någom som har en lösning?
Tacksam för alla tips

Senast redigerat 2019-12-04 12:25
Skrivet av MrS1monsson:

Hej!

Har lite problem men att installera windows 10 och söker lite hjälp.

Jag ska alltså göra en ny ren installation med usb.
Använder mig av microsofts egna verktyg för usb

Problem 1:
Windows cannot be installed to this disk. The selected disk is not of the GPT partition style.

Löste det genom de här stegen.

Follow these steps -

1. At installation screen press Shift+F10 or Fn + Shift + F10 keys at the same time.

2. You will get Command Prompt at installation screen.

3. Type "Diskpart" and hit Enter.

4. Type "list disk" hit Enter.

5. It will show you all the disk into your computer. Now type "Select disk 'disk_no.'" Like "select disk 0" Hit Enter.

6. Type "clean" and hit Enter, cleaning your hard disk will erase the whole disk so be careful if you have any data on the disk. Make a backup before cleaning the disk.

7. Type "convert gpt" and hit enter.

If GPT doesn't work for you the Type "convert mbr" OR "convert basic".

8. Exit the command prompt and proceed with the Windows installation.

Jag kunde då installera windows

Problem 2.
windows 10 cannot be installed to this disk hardware may not support booting.

Försökt fixa med det här.

Compatibility Support Mode - set to [DISABLED]

Secure Boot

1- The M.2 drive has to be the only drive installed.

2 - Go into the BIOS, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, not Windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows 10 will now start installing to your NVME drive as it has its own NVME driver built in.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that Windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode. (see #3 above)

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and Windows will finish the install. Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives.

Men jag fastnar på steg 8. Efter windows installationen syns inte ssd:en i bios? Trots att installationen gick bra? Någom som har en lösning?
Tacksam för alla tips

Tja

Stäng av Secure Boot under installationen, när windows är installerat gå in i bios och ta "clear secure boot keys" . Och aktivera secure boot kommer nog funka

// 11

Känner igen det här från tidigare tråd, minns ej felet men tror det var USB-stickan som var problemet.
Kan du fota skärmen när du ska välja vilken partition du ska installera Windows på? Det skall bara finnas en och den ska inte vara formatterad.

Eller har du löst installationen enligt problem 1?

Skrivet av Oneone:

Tja

Stäng av Secure Boot under installationen, när windows är installerat gå in i bios och ta "clear secure boot keys" . Och aktivera secure boot kommer nog funka

// 11

Hej tack för svar!

Det här steget

3 - Click on secure boot option below and make sure it is set to other OS, not Windows UEFI

Ska jag skippa det? Kommer inte ihåg vilka alternativ som finns men ska försöka stänga av helt då! Har inte så bra koll på det här med UEFI, secure boot hehe

Skickades från m.sweclockers.com

Skrivet av Mordekai:

Känner igen det här från tidigare tråd, minns ej felet men tror det var USB-stickan som var problemet.
Kan du fota skärmen när du ska välja vilken partition du ska installera Windows på? Det skall bara finnas en och den ska inte vara formatterad.

Eller har du löst installationen enligt problem 1?

Hej tack för svar!

När jag löste första problemet så tog jag bort alla partioner på disken, så det var endast en kvar.
Hade även kopplat ur alla andra diskar. Så fanns bara en oformaterad partion att välja när jag starta installationen.

Fasen ifall det är usb:en men testa installera på min gamla sata ssd och du funka allt som vanligt.

Skickades från m.sweclockers.com

Kanske inte hjälper dig men jag installerade Windows på en M.2 NVME i förrgår.

Fick först samma meddelande om GPT.
Men det enda jag gjorde var att dra ut mina 2 andra SSD:er och ange USB Boot UEFI eller liknande som första Boot Option. Sen rullade allt som vanligt.

Behövde aldrig ändra något med Secure Boot eller annat.
Har ett Asus b450-e Rog strix

Skickades från m.sweclockers.com

Skrivet av MrS1monsson:

Hej tack för svar!

När jag löste första problemet så tog jag bort alla partioner på disken, så det var endast en kvar.
Hade även kopplat ur alla andra diskar. Så fanns bara en oformaterad partion att välja när jag starta installationen.

Fasen ifall det är usb:en men testa installera på min gamla sata ssd och du funka allt som vanligt.

Skickades från m.sweclockers.com

Löste du problemet så har du väl installerat windows? Jag fattar inte hur problem 2 också handlar om att installera windows.

Skrivet av Mordekai:

Löste du problemet så har du väl installerat windows? Jag fattar inte hur problem 2 också handlar om att installera windows.

Var otydlig där.
Jag löste problem 2 så kunde jag börja installera windows. Dock fastnar jag på steg 8 när datorn startar om. Så egentligen ett tredje problem. Ska ändra första inlägget!

Skickades från m.sweclockers.com

Senast redigerat 2019-12-04 12:26
Skrivet av MrS1monsson:

Var otydlig där.
Jag löste problem 2 så kunde börja installera windows. Dock fastnar jag på steg 8 när datorn startar om. Så egentligen ett tredje problem. Ska ändra första inlägget!

Skickades från m.sweclockers.com

Installerar du Windows 10 1909?

Skrivet av Oneone:

Installerar du Windows 10 1909?

Yes precis!

Skrivet av kenny_85:

Kanske inte hjälper dig men jag installerade Windows på en M.2 NVME i förrgår.

Fick först samma meddelande om GPT.
Men det enda jag gjorde var att dra ut mina 2 andra SSD:er och ange USB Boot UEFI eller liknande som första Boot Option. Sen rullade allt som vanligt.

Behövde aldrig ändra något med Secure Boot eller annat.
Har ett Asus b450-e Rog strix

Skickades från m.sweclockers.com

Hmm okej intressant kanske aldrig skulle ha pillat med det där GPT..

Skrivet av MrS1monsson:

Hmm okej intressant kanske aldrig skulle ha pillat med det där GPT..

yes, har sett på endel datorer beroende på BIOS version att om man installerar Windows 10 1909 så måste man köra en "clear secure boot keys" efter att windows är installerat.

Skrivet av Oneone:

yes, har sett på endel datorer beroende på BIOS version att om man installerar Windows 10 1909 så måste man köra en "clear secure boot keys" efter att windows är installerat.

Okej jag gör om allt. Jag konverterar tillbaka disken till mbr. Nollar bios och tar bort alla diskar så får vi se.

Skickades från m.sweclockers.com

Skrivet av MrS1monsson:

Okej jag gör om allt. Jag konverterar tillbaka disken till mbr. Nollar bios och tar bort alla diskar så får vi se.

Skickades från m.sweclockers.com

Det lättaste är.

kör diskpart clean så att du inte har något alls på disken.

Aktivera UEFI Secure boot OFF
starta windows installern låt den partitionera disken.

när allt e klart

clear secure boot keys och aktivera secure boot.

Skrivet av Oneone:

Det lättaste är.

kör diskpart clean så att du inte har något alls på disken.

Aktivera UEFI Secure boot OFF
starta windows installern låt den partitionera disken.

när allt e klart

clear secure boot keys och aktivera secure boot.

Kanon jag gör så! Tack så mycket för hjälpen 👍

Skickades från m.sweclockers.com

Skrivet av MrS1monsson:

Kanon jag gör så! Tack så mycket för hjälpen 👍

Skickades från m.sweclockers.com

OM du ser något såhär, ta bort allt sen klicka på next bara.

Skrivet av Oneone:

Japp nu har jag testat med allt du skrev. Och testat andra tips jag har googlat... Får igång windows installationen men sen när datorn startar om så hittar den inte disken. Tror jag ger upp och installerar på min vanliga 128gb ssd istället :/

Skrivet av MrS1monsson:

Japp nu har jag testat med allt du skrev. Och testat andra tips jag har googlat... Får igång windows installationen men sen när datorn startar om så hittar den inte disken. Tror jag ger upp och installerar på min vanliga 128gb ssd istället :/

ahhh då vet jag nog vad det är, du måste ladda in drivers vid installationen innan du installerar windows skulle jag gissa på

Skrivet av Oneone:

ahhh då vet jag nog vad det är, du måste ladda in drivers vid installationen innan du installerar windows skulle jag gissa på

Okej, hehe så det måste man göra med nvme diskar? Känner mig rätt dum isåfall 🤣 har installerat nu på gamla ssd:en och fått in alla program men stör mig att jag inte lyckades lösa det

Skickades från m.sweclockers.com

Skrivet av Oneone:

ahhh då vet jag nog vad det är, du måste ladda in drivers vid installationen innan du installerar windows skulle jag gissa på

Skrivet av MrS1monsson:

Okej, hehe så det måste man göra med nvme diskar? Känner mig rätt dum isåfall 🤣 har installerat nu på gamla ssd:en och fått in alla program men stör mig att jag inte lyckades lösa det

Skickades från m.sweclockers.com

Kan det vara så att han har RAID läge aktivt?

NVMe/AHCI drivare ska ju finnas med Windows...

Skrivet av Paddanx:

Kan det vara så att han har RAID läge aktivt?

NVMe/AHCI drivare ska ju finnas med Windows...

Hmm ja windows borde ju duga för o starta?
Börjat kolla ifall uppdatera firmware på disken kan va något.. är en 970 evo pro 1gb jag har.

Skickades från m.sweclockers.com

Skrivet av MrS1monsson:

Hmm ja windows borde ju duga för o starta?
Börjat kolla ifall uppdatera firmware på disken kan va något.. är en 970 evo pro 1gb jag har.

Skickades från m.sweclockers.com

Samsung har ju drivare du kan ladda ner om du behöver. Och ja, FW uppdatering är alltid en fördel, om du kan göra det.

Skall inte behöva några drivare vid installationen.
Vilket moderkort har du?

Skippa konvertering via cmd och gör allt vid installationen.
När du kommer till rutan som @Oneone lagt upp så tar du bort alla partitioner och skapar en ny av allt tillgängligt utrymme.
När det är gjort så fortsätt installationen, det bör då komma upp att disken formateras och installationen går igång efter det.

Se även till att du inte har andra diskar anslutna under installationen.