Problem vid hårvarukloning

Problem vid hårvarukloning

Jag har köpt en sådan här:

Jag testade med att klona från en SSD-disk till en annan exakt likadan.
Normalt när jag kopierar över 250 Gb filer via USB tar det flera dagar. Med denna apparat tog det mindre än en halvtimma. Så kort tid att kopiera en hel disk har jag aldrig sett förut. Kanon alltså!

Men hårdvarukloning verkar ha ett pris som man visserligen kan leva med men är irriterande. Så här är det:

- Först klonade jag.

- Kopplade in den klonade disken via USB till dator och där dök den upp och enligt vad jag kunde se var den identisk med den andra hårddisken.

- Kopplade sedan in originaldisken också via USB men den dök inte upp.

- Öppnade "Diskhantering" och där fanns båda USB-diskarna men den jag kopplat in sist hade ett rött kryss överst längst till vänster. Det stod något med att den kolliderar med annan disk.

- Jag drog ut båda diskarna och satte bara in originaldisken denna gång. Den dök upp och fungerade fint.

- Satte nu in den klonade disken. Nu dök inte den upp men i "Diskhantering" fanns den med det där lilla krysset.

Jag misstänker att vid hårdvarukloning ser datorn två helt identiska diskar och kopplar inte in den som sätts sist?!

Jag gjorde sedan ett annat test. Jag satte in båda diskarna i datorn via SATA. Innan hade jag en SATA-disk (D) och en M2 (C). Startade datorn och såg nu ingen SATA-disk. Bara M2 som inte är en SATA syntes vilket den borde göra eftersom Windows kunde startas.
Tog ur den klonade disken och startade datorn. Nu dök D-disken upp men inte disken jag klonade från.
Tog ur även disken jag klonade och startade datorn. Datorn startade som vanligt.

Första felet att ingen disk syntes (utom M2) kan bero på att det är en konflikt mellan diskarna jag klonade från och till men disken jag klonade från borde dyka upp när bara den sitter i ett SATA-uttag men det gjorde den inte.

Jag gjorde en snabbformatering av den klonade disken och gjorde om testerna här ovan. Exakt samma problem.

Frågorna är:

1. Kan man sätta in diskar som formaterats genom USB i SATA?
2. Kan en hårdvarukloning göra att de två diskarna inte fungerar tillsammans.
3. När man hårdvaruklonat en disk måste man göra en djupformatering som tar flera timmar för att den skall fungera som en egen disk igen?

Som vanligt kommer jag att vända alla stenar tills jag (med er hjälp) hittar felet.

Nu har jag djupformaterat den klonade hårddisken men det är samma fel!

Alltså:

1. Den tidigare klonade men nu djupformaterade hårddisken och hårddisken som det klonades från kan inte vara öppna samtidigt?!

2. Den andra hårddisken som aldrig klonats till eller gjorts något annat med kan utan problem öppnas samtidigt som hårddisken det klonats från.

Alltså:
Vid hårdvarukloning klonas också hårddiskens fabriksnummer. Två hårddiskar kan inte ha samma nummer:

Klonat från: 14C88F099484&0

Klonat till: 14C88E097232&0

Nya som inte använts: 000000000033&0

Som vi ser har de diskar som inte fungerar ihop samma fabriksnummer trots en djupformatering.
Sannolikt eller helt säkert får den disken man klonar till samma nummer som den det klonas från. Uppenbarligen är det via detta nummer som hårddiskarna skils från varandra i datorn.

Nu är fråga: Hur ändrar man tillbaka numret??

Men egentligen gör det inte så mycket för man använder aldrig den klonade disken samtidigt som den man klonar från om man hårdvarukloner. Den ena användas medan den andra bara är en backup som förhoppningsvis aldrig kommer att användas mer än som en backup.

Jag hade gissat på att problemet var Disk Signature Collission, men det verkar ju inte så troligt om djupformattering inte hjälper.

Alternativhypotesen blir då är att det är något problem med USB-adresseringen. Att Windows är så hjärndött att det bara använder enhetens uppgifter om dess id för att adressera den. Du skulle kunna mounta diskarna i Linux för att kolla om det fungerar där, gissningsvis använder Linux hårdvaran på USB-hosten (datorn) som enheterna är ansluten till för att adressera enheterna.

Skrivet av KAD:

Jag hade gissat på att problemet var Disk Signature Collission, men det verkar ju inte så troligt om djupformattering inte hjälper.

Alternativhypotesen blir då är att det är något problem med USB-adresseringen. Att Windows är så hjärndött att det bara använder enhetens uppgifter om dess id för att adressera den. Du skulle kunna mounta diskarna i Linux för att kolla om det fungerar där, gissningsvis använder Linux hårdvaran på USB-hosten (datorn) som enheterna är ansluten till för att adressera enheterna.

Är nog Signature Collission. Tror inte en Windows djupformatering skriver om MBR/GPT blocken.

Skrivet av KAD:

Jag hade gissat på att problemet var Disk Signature Collission, men det verkar ju inte så troligt om djupformattering inte hjälper.

Alternativhypotesen blir då är att det är något problem med USB-adresseringen. Att Windows är så hjärndött att det bara använder enhetens uppgifter om dess id för att adressera den. Du skulle kunna mounta diskarna i Linux för att kolla om det fungerar där, gissningsvis använder Linux hårdvaran på USB-hosten (datorn) som enheterna är ansluten till för att adressera enheterna.

Skrivet av SAFA:

Är nog Signature Collission. Tror inte en Windows djupformatering skriver om MBR/GPT blocken.

Ja, det är signaturkollision!
Hur fixar man det?

@workman: Tips och trix från Google: https://neosmart.net/wiki/disk-signature-collision/

Jag hade kört med diskpart-alternativet (längst ned)
Se bara till att välja rätt disk

Skrivet av GreyWilk:

@workman: Tips och trix från Google: https://neosmart.net/wiki/disk-signature-collision/

Jag hade kört med diskpart-alternativet (längst ned)
Se bara till att välja rätt disk

Härligt!
Jag skall titta på det så får vi se om jag använder det. Eftersom kopian aldrig används tillsammans med originalet är det inte nödvändigt om det är svårt och förenat med andra risker.

Skrivet av GreyWilk:

@workman: Tips och trix från Google: https://neosmart.net/wiki/disk-signature-collision/

Jag hade kört med diskpart-alternativet (längst ned)
Se bara till att välja rätt disk

FIXAT!!!

Det var ju enkelt!
Jag körde det näst längs ner (#3) först för det var enklast:

1. Starta Diskhanteraren
2. Högerklicka på texten "Offline" i vänsterkant
3. Klicka på texten "Online" i menyn som dyker upp.
4. Klart

Disken kom online och dök upp en sekund efter man klickat på "Online".

Tack för hjälpen!!!

@workman: Gott mos! No worries!
Cheers!

Skrivet av GreyWilk:

@workman: Gott mos! No worries!
Cheers!